No WorkingTree exists after branching project source

Asked by amartino on 2013-03-04

Hello there!

I'm trying to branch a project on launchpad, try to apply a patch and submit it for testing. I'm trying to branch it locally first where the initial patch development will take place on the cutting edge project source.

I've done the following:

bzr init-repo Desktop/appy/bazzar/
    Shared repository with trees (format: 2a)
    Location:
      shared repository: Desktop/appy/bazzar

bzr branch lp:appy Desktop/appy/bazzar/
    You have not informed bzr of your Launchpad ID, and you must do this to
    write to Launchpad or access private data. See "bzr help launchpad-login".
    Doing on-the-fly conversion from RepositoryFormatKnitPack1() to RepositoryFormat2a().
    This may take some time. Upgrade the repositories to the same format for better performance.
    Branched 369 revisions.

bzr status
    bzr: ERROR: No WorkingTree exists for "file:///home/alan/Desktop/appy/bazzar/.bzr/

I was hoping to be able to edit the code and do commits, however, i can't find the branched code.
Tips on what am i doing wrong?

Question information

Language:
English Edit question
Status:
Solved
For:
Appy Edit question
Assignee:
No assignee Edit question
Solved by:
amartino
Solved:
2013-03-04
Last query:
2013-03-04
Last reply:
amartino (amartino) said : #1

Did some additional experimenting.
What solved the problem was running

bzr branch lp:appy

in the folder Desktop/appy/bazzar/.

It seems the branch wasn't created right with

bzr branch lp:appy Desktop/appy/bazzar/
.