table of contents update

Asked by dbr9449 on 2013-02-25

I have a document that includes a table of contents which includes some variable names. When I assemble the document with appy and output to pdf, the variables in the table of contents are replaced with the data fields.

But, when i assemble the document and output to odt format, the variables int he table of contents are not replaced with the data fields, while the variables in the body of the document are replaced.

Can you give me any ideas as to what to try? Thanks.

Question information

English Edit question
Appy Edit question
No assignee Edit question
Solved by:
Gaëtan Delannay
Last query:
Last reply:

Dear 9449,

Here is how pod works. The pod renderer generates an odt file as first result. If this is the required output format, pod gives you this odt file. Else (output format is pdf or doc), pod calls LibreOffice in server mode to convert the ods result in pdf or doc. Before asking to perform the conversion, the pod script that calls LibreOffice (appy/pod/ performs things like updating all indexes in the document (including the table of contents).

If you want to produce an odt file, but still want to use to perform a "conversion" from odt to odt (in your case, in order to update indexes), call the renderer with param forceOoCall=True.

Hope this helps!

dbr9449 (dbr9449) said : #2

Worked like a charm. Thanks!


dbr9449 (dbr9449) said : #3

Thanks Gaëtan Delannay, that solved my question.