pdf creation and libreoffice

Asked by omar on 2012-01-20

i'm attempting to generate a PDF file directly when calling render. i have libreoffice running in server mode. when i run my program i get this error:

Traceback (most recent call last):
  File "bar_plot.py", line 237, in <module>
    renderer.run()
  File "/usr/lib/python2.7/dist-packages/appy/pod/renderer.py", line 369, in run
    self.finalize()
  File "/usr/lib/python2.7/dist-packages/appy/pod/renderer.py", line 486, in finalize
    output = self.callOpenOffice(resultOdtName, resultType)
  File "/usr/lib/python2.7/dist-packages/appy/pod/renderer.py", line 443, in callOpenOffice
    raise pe
appy.pod.PodError: An error occurred during the conversion. Doc URL "/home/omar/project/resultFile.pdf.1327017719.431381/result.odt" is wrong. URL seems to be an unsupported one.

note that the temporary url (i think that's what it is) is never generated -- at least i don't see the file. so might the program be generating the wrong path? or is this some other problem?

thanks

omar

Question information

Language:
English Edit question
Status:
Answered
For:
Appy Edit question
Assignee:
No assignee Edit question
Last query:
2012-01-20
Last reply:
2014-06-23
Launchpad Janitor (janitor) said : #1

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

lecbee (b-bellec) said : #2

It looks like it's a common error, so here is how I fixed it.
It's probably that some packages are missing.

On Fedora at least, you have to install:
libreoffice-writer
libreoffice-headless
libreoffice-pyuno
libreoffice-core

So :
# yum install libreoffice-core libreoffice-pyuno libreoffice-headless libreoffice-writer

If your soffice server is still running when you install theses packages, you have to stop and restart it.

Hi there,
Indeed, when an exception is raised, the temporary file is deleted via a "try-finally" statement.

Answered by lecbee.

Can you help with this problem?

Provide an answer of your own, or ask omar for more information if necessary.

To post a message you must log in.