Comments are seen as empty, even though they're not

Asked by Mathieu Agopian on 2010-12-29


i've been trying and playing around with pod for a few hours now, and it looks like a very nice and clever solution.

On to my issue: i'm trying to use "notes" to specify POD statements like:

"do row for foo in bar"

To do that, i place the cursor on the beginning of the first cell of a row, and insert a "comment" (CTRL + ALT + N). I believe a "note" is in fact a "comment", as i nowhere see anything closer to what looks like a note in your examples.

However, when i render the template to an odt file, there's a comment, where i created mine, stating:

"Syntax error while parsing a note whose content is "[]". In a note, you may .........."

I don't get why it's saying there's no content, when there's one.
I also tried some other statements like :

"do text from xhtml('<p>test</p>')"

but those too ended the same way.

Best regards


P.S: in the docs, you state that to convert to pdf, you need openoffice started in server mode, and thus, need a X server installed and running. However, i found out in various places, including that it is indeed possible (and fairly easy) to install openoffice and launch it in headless mode.

Question information

English Edit question
Appy Edit question
No assignee Edit question
Solved by:
Gaëtan Delannay
Last query:
Last reply:

I also tried putting my comments on two lines, but that had the same effect :

do text
from '<text:p>test</text:p>'

It still tells me that my comment is "[]" (which isn't much, is it? ;)



Yes, this is right, "from ..." must be on a single line.
The bug you encounter is pretty old: it happens with old POD versions that are given templates that run with OpenOffice >= 3.0. What POD version do you use?
Note that the eggified version of appy.pod on PyPy is deprecated (easy_installl appy.pod). A pretty good old zip file is available on this website.

Thanks Gaëtan Delannay, that solved my question.

Tobia (tobia) said : #4

This bug might be old, but until a newer version is made available on the pip index, everybody wil get bitten by it.

Seriously, why can't POD be installed with pip like everything else?