python3 error on elementary os Luna

Asked by Niket on 2013-09-28

I have added the appgrid stable repo and also updated the repos using apt-get update, however when installing appgrid, it says:
http://i.imgur.com/aPa6COu.png

I tried installing python3 but then it gave a whole bunch of errors so I just uninstalled it.

Elementary OS Luna is based on Ubuntu 12.04 LTS so App Grid should work on it.

Can you please look into this and let me know how to fix it?

Question information

Language:
English Edit question
Status:
Answered
For:
App Grid Edit question
Assignee:
No assignee Edit question
Last query:
2013-09-28
Last reply:
2014-01-14
pgg (pgg) said : #1

Hi - App Grid currently doesn't work on elementary OS - there is a bug open about that, but I will need to install elementary os and modify the App Grid code before it will work (the difference is that elementary OS doesn't identify itself as precise, rather as luna) - hope that helps!

aleksdj (aleksdj) said : #2

You can edit -temporally- your /etc/lsb-realase file and change DISTRIB_CODENAME=luna to DISTRIB_CODENAME=precise. Now it works and it opens. But im afraid there will be some problems after that, so you can turn it back after use appgrid.
regards

pgg (pgg) said : #3

The latest release of App Grid should now run on Elementary OS "Luna" - hope you enjoy :)

chest069 (chest069) said : #4

When running appgrid I get the following error:

"/usr/share/appgrid/appgrid.py:17: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded.
  from gi.repository import Gtk, Gdk
/usr/share/appgrid/appdata/helpers.py:9: PyGIWarning: Soup was imported without specifying a version first. Use gi.require_version('Soup', '2.4') before import to ensure that the right version gets loaded.
  from gi.repository import GLib, GObject, Soup
python3: ../../../../src/cairo-surface.c:1653: cairo_surface_mark_dirty_rectangle: Assertion `! _cairo_surface_has_mime_data (surface)' failed.
/usr/bin/appgrid: line 25: 6378 Aborted /usr/share/appgrid/appgrid.py "$@"

 any idead on how to get appgrid to run on Ubuntu 15.10 Amd64?

pgg (pgg) said : #5

Hi Chris,

You might be running Ubuntu GNOME, rather than regular Ubuntu? They offer some more recent versions of software than Ubuntu itself uses. Unfortunately there seems to be a bug in one of these components which causes App Grid to crash. Good news is the latest version of App Grid should avoid these issues - you can download the most recent version from www.appgrid.org and install it manually - I will make it available as an update in the coming days for those who already have App Grid installed.

Thanks for getting in touch,

Can you help with this problem?

Provide an answer of your own, or ask Niket for more information if necessary.

To post a message you must log in.