How to build?

Asked by Camilo Higuita on 2012-12-17

I can't seem to build this from source and when i tried the ppa to install libappstore-dev it said: libsqlheavy-dev Depends: libsqlheavy0.1-0 (=0.1.0-1) but 0.1.1-2 is to be installed.

How to try appcenter? is it possible yet?

Question information

Language:
English Edit question
Status:
Answered
For:
AppCenter Edit question
Assignee:
No assignee Edit question
Last query:
2012-12-17
Last reply:
2012-12-18
Mario Guerriero (mefrio-g) said : #1

there are problems with the dependecies for precise. I am working on them. Now you can build it manually (libappstore and then appcenter)

Camilo Higuita (kxmylo) said : #2

I tried building manually libappstore but i keep having problems with the version of sqlheavy (the version installed is 0.1.1-2)

-- checking for modules 'packagekit-glib2;sqlheavy-0.1;gtk+-3.0;gio-2.0;gee-1.0'
-- package 'sqlheavy-0.1' not found
CMake Error at /usr/share/cmake-2.8/Modules/FindPkgConfig.cmake:266 (message):
  A required package was not found
Call Stack (most recent call first):
  /usr/share/cmake-2.8/Modules/FindPkgConfig.cmake:320 (_pkg_check_modules_internal)
  lib/CMakeLists.txt:31 (pkg_check_modules)

Mario Guerriero (mefrio-g) said : #3

you are missing libsqlheavy. I fixed deb packaging however. If you wait a few hours you will be available to install AppCenter from the ppa.

Can you help with this problem?

Provide an answer of your own, or ask Camilo Higuita for more information if necessary.

To post a message you must log in.