The stop button does nothing and can't kill the program

Asked by Javier on 2015-04-18

I'm running this on Ubuntu (14.10) Gnome (3.14).

When I run the program without GUI it works fine and integrates well with the Shell menu, but I found no way to kill it. I can pause it, the stop button does nothing and I found no other way to kill it. I can't even find a processes called "anoise" that I can kill.

I've installed the GUI an also works fine. I've noticed that it has a pause button but no stop, which might explain why the stop button in the Shell interface doesn't do anything. When I close the GUI window, the program shuts down nicely and there is a process called anoise running.

How can I stop/close the application without having to run it in a window? Is the stop button meant to do anything? If not, I would strongly suggest that it stops the program so it can liberate resources and space in the Shell menu.

Thanks

Question information

Language:
English Edit question
Status:
Solved
For:
ANoise Edit question
Assignee:
No assignee Edit question
Solved by:
costales
Solved:
2015-04-28
Last query:
2015-04-28
Last reply:
2015-04-18
Best costales (costales) said : #1

Hi Javier!

The goal is to integrate it into the sound indicator, then you can't close it. The pause it's the same to stop. The RAM used is really small.
The Unity sound indicator hasn't stop (just previous, play/pause, next), by that is not working in the GNOME extension. That stop button is a dummy button for ANoise.

The proccess is this:
python /usr/share/anoise/anoise.py

You could kill ANoise with a command like this:
kill $(ps aux | grep 'python /usr/share/anoise/anoise.py' | awk '{print $2}')

Best regards!

Javier (javiergarcia77-gmail) said : #2

Thank you for the reply