alltray -p not an option

Asked by luke on 2009-11-20

I am trying to send a window to the tray using the process ID, which it says I can do in the documentation, see link

http://alltray.trausch.us/wiki/Documentation

I have version 0.69 and there is no -p option. I there an alternative version I can use or is this no longer available?

Luke

Question information

Language:
English Edit question
Status:
Solved
For:
AllTray Edit question
Assignee:
No assignee Edit question
Solved by:
luke
Solved:
2009-11-23
Last query:
2009-11-23
Last reply:
2009-11-21
Michael B. Trausch (mtrausch) said : #1

HI,

The documentation there is for the new AllTray (that is, the one that you can find in the trunk branch here on Launchpad; it has not been integrated into Ubuntu or other distributions at this time).

However, if you have the old AllTray installed, you should be able to “man alltray” on your system to view documentation for the version that you have. (If you want to print that documentation, you can do so by “man -t alltray | lp” if you have a printer configured.)

luke (swisstone198) said : #2

Thanks for the reply.

When I try to install the lastest version, I do a ./configure and it complains that I dont have X11 installed, how do I get around this error? I believe I do have X11 installed. I'm running ubuntu Karmic.

Thanks for any help

Luke

Michael B. Trausch (mtrausch) said : #3

Ahh. I probably need to teach ./configure to give more meaningful error messages.

You need the development headers for X11, GDK, GTK, libgtop, and libwnck on your system. If you're running Ubuntu:

 $ sudo aptitude install libx11-dev libgtk2.0-dev libgtop2-dev libwnck-dev

That should do it.

Note that the new AllTray does not yet have close-to-tray, I'm still researching how to do that cleanly, portably, and deterministically. The old AllTray worked in the case of GNOME and Metacity, but failed in various ways with other window managers, and even under GNOME, drag-and-drop didn't work properly. I don't want any of those issues in new AllTray, so for the moment, it just doesn't have close-to-tray.

Michael B. Trausch (mtrausch) said : #4

Oh, and also, you'll need to install build-essential, add that to the line above if it isn't pulled in automatically.

luke (swisstone198) said : #5

Thanks very much guys. Works a treat. Really appreciate it.

Luke