AllTray & Cairo-dock

Asked by hollen ar mor on 2009-10-23

 I use Alltray at Ubuntu startup to start Thunderbird reduced in the tray. For that, I added the line "alltray thunderbird" in the list of programs at startup. I also use Cairo-Dock. I put a shortcut to open and close Thunderbird. In the previous version of Ubuntu, I assigned the command "thunderbird alltray &&", which allowed me to go out and return the Thunderbird in the tray.
Now this command does not work anymore.
What is the command to exit an application from the tray?

Thank you for your answers!

Question information

Language:
English Edit question
Status:
Solved
For:
AllTray Edit question
Assignee:
No assignee Edit question
Solved by:
hollen ar mor
Solved:
2009-10-30
Last query:
2009-10-30
Last reply:
2009-10-29
Michael B. Trausch (mtrausch) said : #1

I'm not entirely certain that I understood your question. I'll try to answer the questions I see, and if I'm wrong, please come back and clarify for me, if possible. Thanks!

 * To start AllTray with a program, just "alltray PROGNAME", as you already do.
 * The application should then show up in the system tray, where you can show and hide it at will.
 * To exit the application, use it's built-in option to quit. Usually this is File→Quit or File→Exit or similar.
 * To tell AllTray to stop managing the application, right-click on the icon in the system tray and "undock".

These steps should be correct independent of your version of AllTray. However, if I haven't answered your question, please let me know—and also let me know which version of AllTray you're running. Thank you!

Sorry if I wasn't clear...
My question is to find a command line to exit an application from the tray.
As I said, I have Thunderbird reduced in the tray with AllTray at startup. This works very good.
But now, I want to find a non-graphical command to exit TB from the tray. Indeed, I use Cairo-dock with a TB shortcut and I want this shortcut to make TB exit from the tray.
Before, if I remember well, I used "alltray thunderbird &&" and TB appeared. But since I use the new Ubuntu Karmic Koala, it doesn't work anymore.
An idea why ?

Thanks for your answers !

Michael B. Trausch (mtrausch) said : #3

I don't think I am understanding you.

The command "alltray thunderbird" will start AllTray, which will itself then start Thunderbird running underneath it. The "&&" afterward is unnecessary; that's a shell programming construct that says "only run the next command if the command I'm specifying before the “&&” exits with success".

To undock Thunderbird, you have to right-click on the tray icon and undock. To exit Thunderbird, you have to click File→Quit (or whatever other method Thunderbird requires of exiting the application cleanly).

Are you saying that AllTray in Karmic isn't working with Thunderbird in Karmic?

OK.
I want to undock Thunderbird without clicking on the tray icon.
When I prompt "alltray thunderbird" in a terminal, nothing happens... Why ?
Is there something wrong with OpenGL ?

Michael B. Trausch (mtrausch) said : #5

Alright, so for starters, the only way that you can undock Thunderbird without clicking on the tray icon is to kill AllTray. I don't know if that will result in a clean detachment, though, so I do *not* recommend it.

Assuming that you're using the version of AllTray that comes with Karmic, do this:

 alltray -d thunderbird

And see what you get for debugging output. Come back here and paste that in and I'll take a look at it. I will try to replicate the problem, as well, later on today or tomorrow.

Killing TB isn't good for me. After I can't dock it back instead of quit...
When I make "alltray -d thunderbird", I have this :

hollen@Edouard:~$ alltray -d thunderbird
command without args: thunderbird
basename: thunderbird
command: thunderbird
win->title_time: 0
win->notray: 0
HAVE MANAGER WINDOW
win->libsyp_window id: 69206019
execute program: thunderbird
lib is here: /usr/lib
old preload: (null)
preload string: LD_PRELOAD=/usr/lib/liballtray.so.0.0.0
wait for window
map notify
filter mapped window: 0x1a000a6 "alltray"window int: 27263142

override redirect -> skip

And when I undock TB clicking on the tray icon, this more :

map notify
filter mapped window: 0x1a00004 "Courrier entrant pour <email address hidden> - Thunderbird (AllTray)"window int: 27262980

window got through first filter
PID found: yes
PID match: no
process group id: 1835
process id match: no
PID found: no
found strings: res_class: Alltray res_name alltray
res name down: alltray
command down: thunderbird
map notify
filter mapped window: 0x1441d2a (has no name)window int: 21241130

override redirect -> skip
map notify
filter mapped window: 0x3e0015e "Terminal"window int: 65012062

override redirect -> skip
map notify
filter mapped window: 0x3e0015f "Terminal"window int: 65012063

override redirect -> skip
map notify
filter mapped window: 0x3e00261 "Terminal"window int: 65012321

override redirect -> skip
map notify
filter mapped window: 0x3e0015f "Terminal"window int: 65012063

override redirect -> skip
map notify
filter mapped window: 0x3e00420 "Terminal"window int: 65012768

override redirect -> skip
map notify
filter mapped window: 0x38000e0 "Thunderbird"window int: 58720480

override redirect -> skip

Do you think there is something to do with xbindkeys ?

Michael B. Trausch (mtrausch) said : #7

What do you mean when you say "undock"? "Undocking" is the process of making AllTray go away completely, not showing the application window.

Can you try the latest testing version of AllTray (0.7.4dev, available in the AllTray Developers' PPA) and see if it works with Thunderbird in Karmic?

Sorry. When I said "undock" I mean "show".
I just install your last version :

hollen@Edouard:~$ alltray man
AllTray 0.7.4dev
Copyright (c) 2009 Michael B. Trausch <email address hidden>
Licensed under the GNU GPL v3.0 as published by the Free Software Foundation.

Thanks a lot for the work !

So, now, when Ubuntu startup, TB isn't reduce in the tray : the window is opened on the desk... And when I close TB, I think it close totally : I don't have any icon in the tray...

I tried to launch TB 'normally'. When I click with AllTray in it, nothing happens but TB icon in the tray. I have to click on this icon to hide TB... Not easy...

When I click on my dock icon (which is "alltray thunderbird"), it makes twinkle the TB tray icon, and that's all. No window opened...

The old version is better for me...

Michael B. Trausch (mtrausch) said : #9

On Wed, 2009-10-28 at 21:24 +0000, hollen ar mor wrote:
> The old version is better for me...

Can you record a screencast that shows me what's going on? I still do
not understand, I am sorry.

 --- Mike

--
Blog: http://mike.trausch.us/blog/
Misc. Software: http://mike.trausch.us/software/

“The greater danger for most of us lies not in setting our aim too
high and falling short; but in setting our aim too low, and achieving
our mark.” —Michelangelo

Hi !
Sorry for not being able to speak clearly: the English is not my mother tongue ...
By installing the final version of Karmic out yesterday, I realized that the problem does not come from alltray, but Cairo-Dock.
Indeed, as I do not install the driver 185 of my NVidia graphic card, the shortcut with the command "alltray thunderbird" works very well (with the old version of alltray in the Ubuntu deposits, I will also test with the last you just realease, but I think it will be the same).

There is therefore a problem with OpenGL or something with the graphics. I shall therefore turn to the developers of Cairo-dock to make up information.

Thank you for all the time that you kindly grant me in all cases and sorry to have bothered you with a problem that does not concern you.

Best regards !

Michael B. Trausch (mtrausch) said : #11

It has been no trouble at all. Thank you for letting me know what's going on, and best of luck in solving your problem!

I forgot ...
With the latest version of alltray when I leave Thunderbird (file => quit), it closes completely ... To hide TB in the tray, you must click on the icon in the tray ...

It's done on purpose?

Again, excuse me to bother you ...
I just read this page: http://alltray.trausch.us/wiki/Documentation/Man_Page

I am always surprised that there are not a command to show an application hidden in the tray ...
Like: " alltray - show thunderbird " or something like that ...
You confirm to me that nothing like that exists?

Michael B. Trausch (mtrausch) said : #14

It's no bother.

AllTray _may_ support something like that in the future, however, that's a ways away yet. I have some ideas, but I need to get 0.7.5dev (and the 0.8.0 that follows it) out before I can really explore them more. The problem there is that I'm running into a documentation brick wall, and am having a hard time trying to figure out exactly how to correctly and portably do some of the things that AllTray needs to do.

OK !
Good work and go on !
I'll wait for further version.

Thanks a lot !