Configured audiosink player-audiosink is not working

Asked by Maarten Fokkinga on 2015-01-29

I've Lubuntu (Ubuntu 14.04.1 LTS). When trying to play a sound, alarm clock give the message "file:///usr/share/sounds/purple/alert.wav: Configured audiosink player-audiosink is not working." Also with .oga files. Section "answers" on https://answers.launchpad.net/alarm-clock gives no help on this problem.

Reading web suggestions I've installed gstreamer1.o-alsa and -nice and -pulseaudio (and I've also some gstreamer0.10-...), but the problem remains. What should I do?

Question information

Language:
English Edit question
Status:
Solved
For:
Alarm Clock Edit question
Assignee:
No assignee Edit question
Solved by:
Johannes H. Jensen
Solved:
2015-01-30
Last query:
2015-01-30
Last reply:
2015-01-30
Johannes H. Jensen (joh) said : #1

Sounds like something is wrong with your audio setup. Does audio work in other applications such as Totem Video Player?

Does the following command work and produce a sound?

gst-launch-1.0 -v -m audiotestsrc ! audioconvert ! audioresample ! autoaudiosink

Sound files (.wav and .oga) produce sounds with GNOME Player and with Audacious.

Installing Totem Video Player did not resolve the problem; I do have now:
/usr/bin/totem
and playing a video (MP4) does produce sound, but it also produces a warning:
(totem:5229): Gtk-WARNING **: Calling Inhibit failed: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files

Command "gst-launch-1.0 -v -m audiotestsrc..." produces the error message "command not found: gst-launch-1.0".
The description o package rel-gst-launch says "This package provides a gst-launch plugin...", so I installed it. Alas; both "locate gst-launch-1.0" and "which gst-launch-1.0" confirm that gst-launch-1.0 is not present (and similarly for gst-launch). However, "locate gst-launch" gives:
/usr/lib/rygel-2.0/plugins/gst-launch.plugin
/usr/lib/rygel-2.0/plugins/librygel-gst-launch.so
/usr/share/doc/rygel-gst-launch
/usr/share/doc/rygel-gst-launch/changelog.Debian.gz
/usr/share/doc/rygel-gst-launch/copyright
/var/cache/apt/archives/rygel-gst-launch_0.20.3-1ubuntu2_i386.deb
/var/lib/dpkg/info/rygel-gst-launch.list
/var/lib/dpkg/info/rygel-gst-launch.md5sums

I cannot find gst-launch nor gst-launch-1.0 with Lubuntu Software Center, nor with Synaptic Package manager.

What can/should I do next?

I filled in an answer on
https://answers.launchpad.net/alarm-clock/+question/261400

2015-01-30 17:31 GMT+01:00 Johannes H. Jensen
<email address hidden>:
> Your question #261400 on Alarm Clock changed:
> https://answers.launchpad.net/alarm-clock/+question/261400
>
> Status: Open => Needs information
>
> Johannes H. Jensen requested more information:
> Sounds like something is wrong with your audio setup. Does audio work in
> other applications such as Totem Video Player?
>
> Does the following command work and produce a sound?
>
> gst-launch-1.0 -v -m audiotestsrc ! audioconvert ! audioresample !
> autoaudiosink
>
> --
> To answer this request for more information, you can either reply to
> this email or enter your reply at the following page:
> https://answers.launchpad.net/alarm-clock/+question/261400
>
> You received this question notification because you asked the question.

Johannes H. Jensen (joh) said : #4

For gst-launch, install the gstreamer-tools package.

On Fri, Jan 30, 2015 at 8:41 PM, Maarten Fokkinga <
<email address hidden>> wrote:

> Question #261400 on Alarm Clock changed:
> https://answers.launchpad.net/alarm-clock/+question/261400
>
> Status: Needs information => Open
>
> Maarten Fokkinga gave more information on the question:
> Sound files (.wav and .oga) produce sounds with GNOME Player and with
> Audacious.
>
> Installing Totem Video Player did not resolve the problem; I do have now:
> /usr/bin/totem
> and playing a video (MP4) does produce sound, but it also produces a
> warning:
> (totem:5229): Gtk-WARNING **: Calling Inhibit failed:
> GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name
> org.gnome.SessionManager was not provided by any .service files
>
> Command "gst-launch-1.0 -v -m audiotestsrc..." produces the error message
> "command not found: gst-launch-1.0".
> The description o package rel-gst-launch says "This package provides a
> gst-launch plugin...", so I installed it. Alas; both "locate
> gst-launch-1.0" and "which gst-launch-1.0" confirm that gst-launch-1.0 is
> not present (and similarly for gst-launch). However, "locate gst-launch"
> gives:
> /usr/lib/rygel-2.0/plugins/gst-launch.plugin
> /usr/lib/rygel-2.0/plugins/librygel-gst-launch.so
> /usr/share/doc/rygel-gst-launch
> /usr/share/doc/rygel-gst-launch/changelog.Debian.gz
> /usr/share/doc/rygel-gst-launch/copyright
> /var/cache/apt/archives/rygel-gst-launch_0.20.3-1ubuntu2_i386.deb
> /var/lib/dpkg/info/rygel-gst-launch.list
> /var/lib/dpkg/info/rygel-gst-launch.md5sums
>
> I cannot find gst-launch nor gst-launch-1.0 with Lubuntu Software
> Center, nor with Synaptic Package manager.
>
> What can/should I do next?
>
> --
> You received this question notification because you are an answer
> contact for Alarm Clock.
>

(Many thanks so far!!)
I installed gstreamet-tools. Command "locate gstreamer" give many many
lines, the first of which read as follows:
/home/maarten/.gstreamer-0.10
/home/maarten/.cache/gstreamer-1.0
/home/maarten/.cache/gstreamer-1.0/registry.i686.bin
/home/maarten/.gstreamer-0.10/registry.i486.bin
/home/maarten/.gstreamer-0.10/registry.i686.bin
/home/maarten/.wine/drive_c/windows/system32/winegstreamer.dll
/usr/lib/gupnp-dlna/libgstreamer.so
/usr/lib/i386-linux-gnu/gstreamer-0.10
/usr/lib/i386-linux-gnu/gstreamer-1.0
/usr/lib/i386-linux-gnu/gstreamer0.10
/usr/lib/i386-linux-gnu/gstreamer1.0

Alas, "gst-launch-1.0 -v -m audiotestsrc ! audioconvert !
audioresample ! autoaudiosink" gives "command not found:
gst-launch-1.0", but without the "-1.0" I do get a message, namely:
Setting pipeline to PAUSED ...
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
ERROR: Pipeline doesn't want to pause.
Got message #7 from element "autoaudiosink0-actual-sink-jackaudio"
(error): GstMessageError, gerror=(GError)NULL,
debug=(string)"gstjackaudiosink.c\(358\):\
gst_jack_ring_buffer_open_device\ \(\):\
/GstJackAudioSink:autoaudiosink0-actual-sink-jackaudio:\012Cannot\
connect\ to\ the\ Jack\ server\ \(status\ 17\)";
ERROR: from element
/GstJackAudioSink:autoaudiosink0-actual-sink-jackaudio: Jack server
not found
Additional debug info:
gstjackaudiosink.c(358): gst_jack_ring_buffer_open_device ():
/GstJackAudioSink:autoaudiosink0-actual-sink-jackaudio:
Cannot connect to the Jack server (status 17)
Setting pipeline to NULL ...
Freeing pipeline ...

Also, alarm-clock still cannot playu sounds; it still says:
"file:///usr/share/sounds/freedesktop/stereo/phone-incoming-call.oga:
Configured audiosink player-audiosink is not working."

2015-01-30 20:46 GMT+01:00 Johannes H. Jensen
<email address hidden>:
> Your question #261400 on Alarm Clock changed:
> https://answers.launchpad.net/alarm-clock/+question/261400
>
> Status: Open => Answered
>
> Johannes H. Jensen proposed the following answer:
> For gst-launch, install the gstreamer-tools package.
>
> On Fri, Jan 30, 2015 at 8:41 PM, Maarten Fokkinga <
> <email address hidden>> wrote:
>
>> Question #261400 on Alarm Clock changed:
>> https://answers.launchpad.net/alarm-clock/+question/261400
>>
>> Status: Needs information => Open
>>
>> Maarten Fokkinga gave more information on the question:
>> Sound files (.wav and .oga) produce sounds with GNOME Player and with
>> Audacious.
>>
>> Installing Totem Video Player did not resolve the problem; I do have now:
>> /usr/bin/totem
>> and playing a video (MP4) does produce sound, but it also produces a
>> warning:
>> (totem:5229): Gtk-WARNING **: Calling Inhibit failed:
>> GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name
>> org.gnome.SessionManager was not provided by any .service files
>>
>> Command "gst-launch-1.0 -v -m audiotestsrc..." produces the error message
>> "command not found: gst-launch-1.0".
>> The description o package rel-gst-launch says "This package provides a
>> gst-launch plugin...", so I installed it. Alas; both "locate
>> gst-launch-1.0" and "which gst-launch-1.0" confirm that gst-launch-1.0 is
>> not present (and similarly for gst-launch). However, "locate gst-launch"
>> gives:
>> /usr/lib/rygel-2.0/plugins/gst-launch.plugin
>> /usr/lib/rygel-2.0/plugins/librygel-gst-launch.so
>> /usr/share/doc/rygel-gst-launch
>> /usr/share/doc/rygel-gst-launch/changelog.Debian.gz
>> /usr/share/doc/rygel-gst-launch/copyright
>> /var/cache/apt/archives/rygel-gst-launch_0.20.3-1ubuntu2_i386.deb
>> /var/lib/dpkg/info/rygel-gst-launch.list
>> /var/lib/dpkg/info/rygel-gst-launch.md5sums
>>
>> I cannot find gst-launch nor gst-launch-1.0 with Lubuntu Software
>> Center, nor with Synaptic Package manager.
>>
>> What can/should I do next?
>>
>> --
>> You received this question notification because you are an answer
>> contact for Alarm Clock.
>>
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
> https://answers.launchpad.net/alarm-clock/+question/261400/+confirm?answer_id=3
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/alarm-clock/+question/261400
>
> You received this question notification because you asked the question.

Do I need to answer by mail, or should I usee the fill in form on
https://answers.launchpad.net/alarm-clock/+question/261400
?

2015-01-30 20:59 GMT+01:00 Maarten Fokkinga <email address hidden>:
> (Many thanks so far!!)
> I installed gstreamet-tools. Command "locate gstreamer" give many many
> lines, the first of which read as follows:
> /home/maarten/.gstreamer-0.10
> /home/maarten/.cache/gstreamer-1.0
> /home/maarten/.cache/gstreamer-1.0/registry.i686.bin
> /home/maarten/.gstreamer-0.10/registry.i486.bin
> /home/maarten/.gstreamer-0.10/registry.i686.bin
> /home/maarten/.wine/drive_c/windows/system32/winegstreamer.dll
> /usr/lib/gupnp-dlna/libgstreamer.so
> /usr/lib/i386-linux-gnu/gstreamer-0.10
> /usr/lib/i386-linux-gnu/gstreamer-1.0
> /usr/lib/i386-linux-gnu/gstreamer0.10
> /usr/lib/i386-linux-gnu/gstreamer1.0
>
> Alas, "gst-launch-1.0 -v -m audiotestsrc ! audioconvert !
> audioresample ! autoaudiosink" gives "command not found:
> gst-launch-1.0", but without the "-1.0" I do get a message, namely:
> Setting pipeline to PAUSED ...
> Cannot connect to server socket err = No such file or directory
> Cannot connect to server request channel
> jack server is not running or cannot be started
> ERROR: Pipeline doesn't want to pause.
> Got message #7 from element "autoaudiosink0-actual-sink-jackaudio"
> (error): GstMessageError, gerror=(GError)NULL,
> debug=(string)"gstjackaudiosink.c\(358\):\
> gst_jack_ring_buffer_open_device\ \(\):\
> /GstJackAudioSink:autoaudiosink0-actual-sink-jackaudio:\012Cannot\
> connect\ to\ the\ Jack\ server\ \(status\ 17\)";
> ERROR: from element
> /GstJackAudioSink:autoaudiosink0-actual-sink-jackaudio: Jack server
> not found
> Additional debug info:
> gstjackaudiosink.c(358): gst_jack_ring_buffer_open_device ():
> /GstJackAudioSink:autoaudiosink0-actual-sink-jackaudio:
> Cannot connect to the Jack server (status 17)
> Setting pipeline to NULL ...
> Freeing pipeline ...
>
> Also, alarm-clock still cannot playu sounds; it still says:
> "file:///usr/share/sounds/freedesktop/stereo/phone-incoming-call.oga:
> Configured audiosink player-audiosink is not working."
>
>
>
>
> 2015-01-30 20:46 GMT+01:00 Johannes H. Jensen
> <email address hidden>:
>> Your question #261400 on Alarm Clock changed:
>> https://answers.launchpad.net/alarm-clock/+question/261400
>>
>> Status: Open => Answered
>>
>> Johannes H. Jensen proposed the following answer:
>> For gst-launch, install the gstreamer-tools package.
>>
>> On Fri, Jan 30, 2015 at 8:41 PM, Maarten Fokkinga <
>> <email address hidden>> wrote:
>>
>>> Question #261400 on Alarm Clock changed:
>>> https://answers.launchpad.net/alarm-clock/+question/261400
>>>
>>> Status: Needs information => Open
>>>
>>> Maarten Fokkinga gave more information on the question:
>>> Sound files (.wav and .oga) produce sounds with GNOME Player and with
>>> Audacious.
>>>
>>> Installing Totem Video Player did not resolve the problem; I do have now:
>>> /usr/bin/totem
>>> and playing a video (MP4) does produce sound, but it also produces a
>>> warning:
>>> (totem:5229): Gtk-WARNING **: Calling Inhibit failed:
>>> GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name
>>> org.gnome.SessionManager was not provided by any .service files
>>>
>>> Command "gst-launch-1.0 -v -m audiotestsrc..." produces the error message
>>> "command not found: gst-launch-1.0".
>>> The description o package rel-gst-launch says "This package provides a
>>> gst-launch plugin...", so I installed it. Alas; both "locate
>>> gst-launch-1.0" and "which gst-launch-1.0" confirm that gst-launch-1.0 is
>>> not present (and similarly for gst-launch). However, "locate gst-launch"
>>> gives:
>>> /usr/lib/rygel-2.0/plugins/gst-launch.plugin
>>> /usr/lib/rygel-2.0/plugins/librygel-gst-launch.so
>>> /usr/share/doc/rygel-gst-launch
>>> /usr/share/doc/rygel-gst-launch/changelog.Debian.gz
>>> /usr/share/doc/rygel-gst-launch/copyright
>>> /var/cache/apt/archives/rygel-gst-launch_0.20.3-1ubuntu2_i386.deb
>>> /var/lib/dpkg/info/rygel-gst-launch.list
>>> /var/lib/dpkg/info/rygel-gst-launch.md5sums
>>>
>>> I cannot find gst-launch nor gst-launch-1.0 with Lubuntu Software
>>> Center, nor with Synaptic Package manager.
>>>
>>> What can/should I do next?
>>>
>>> --
>>> You received this question notification because you are an answer
>>> contact for Alarm Clock.
>>>
>>
>> --
>> If this answers your question, please go to the following page to let us
>> know that it is solved:
>> https://answers.launchpad.net/alarm-clock/+question/261400/+confirm?answer_id=3
>>
>> If you still need help, you can reply to this email or go to the
>> following page to enter your feedback:
>> https://answers.launchpad.net/alarm-clock/+question/261400
>>
>> You received this question notification because you asked the question.

Johannes H. Jensen (joh) said : #7

Looks like
https://bugs.launchpad.net/ubuntu/+source/gstreamer0.10/+bug/1178272

The fix: install pulseaudio

Doesn't matter whether you answer by e-mail or through the web. Your
message will show up both places :)

On Fri, Jan 30, 2015 at 9:06 PM, Maarten Fokkinga <
<email address hidden>> wrote:

> Question #261400 on Alarm Clock changed:
> https://answers.launchpad.net/alarm-clock/+question/261400
>
> Maarten Fokkinga gave more information on the question:
> Do I need to answer by mail, or should I usee the fill in form on
> https://answers.launchpad.net/alarm-clock/+question/261400
> ?
>
> 2015-01-30 20:59 GMT+01:00 Maarten Fokkinga <email address hidden>:
> > (Many thanks so far!!)
> > I installed gstreamet-tools. Command "locate gstreamer" give many many
> > lines, the first of which read as follows:
> > /home/maarten/.gstreamer-0.10
> > /home/maarten/.cache/gstreamer-1.0
> > /home/maarten/.cache/gstreamer-1.0/registry.i686.bin
> > /home/maarten/.gstreamer-0.10/registry.i486.bin
> > /home/maarten/.gstreamer-0.10/registry.i686.bin
> > /home/maarten/.wine/drive_c/windows/system32/winegstreamer.dll
> > /usr/lib/gupnp-dlna/libgstreamer.so
> > /usr/lib/i386-linux-gnu/gstreamer-0.10
> > /usr/lib/i386-linux-gnu/gstreamer-1.0
> > /usr/lib/i386-linux-gnu/gstreamer0.10
> > /usr/lib/i386-linux-gnu/gstreamer1.0
> >
> > Alas, "gst-launch-1.0 -v -m audiotestsrc ! audioconvert !
> > audioresample ! autoaudiosink" gives "command not found:
> > gst-launch-1.0", but without the "-1.0" I do get a message, namely:
> > Setting pipeline to PAUSED ...
> > Cannot connect to server socket err = No such file or directory
> > Cannot connect to server request channel
> > jack server is not running or cannot be started
> > ERROR: Pipeline doesn't want to pause.
> > Got message #7 from element "autoaudiosink0-actual-sink-jackaudio"
> > (error): GstMessageError, gerror=(GError)NULL,
> > debug=(string)"gstjackaudiosink.c\(358\):\
> > gst_jack_ring_buffer_open_device\ \(\):\
> > /GstJackAudioSink:autoaudiosink0-actual-sink-jackaudio:\012Cannot\
> > connect\ to\ the\ Jack\ server\ \(status\ 17\)";
> > ERROR: from element
> > /GstJackAudioSink:autoaudiosink0-actual-sink-jackaudio: Jack server
> > not found
> > Additional debug info:
> > gstjackaudiosink.c(358): gst_jack_ring_buffer_open_device ():
> > /GstJackAudioSink:autoaudiosink0-actual-sink-jackaudio:
> > Cannot connect to the Jack server (status 17)
> > Setting pipeline to NULL ...
> > Freeing pipeline ...
> >
> > Also, alarm-clock still cannot playu sounds; it still says:
> > "file:///usr/share/sounds/freedesktop/stereo/phone-incoming-call.oga:
> > Configured audiosink player-audiosink is not working."
> >
> >
> >
> >
> > 2015-01-30 20:46 GMT+01:00 Johannes H. Jensen
> > <email address hidden>:
> >> Your question #261400 on Alarm Clock changed:
> >> https://answers.launchpad.net/alarm-clock/+question/261400
> >>
> >> Status: Open => Answered
> >>
> >> Johannes H. Jensen proposed the following answer:
> >> For gst-launch, install the gstreamer-tools package.
> >>
> >> On Fri, Jan 30, 2015 at 8:41 PM, Maarten Fokkinga <
> >> <email address hidden>> wrote:
> >>
> >>> Question #261400 on Alarm Clock changed:
> >>> https://answers.launchpad.net/alarm-clock/+question/261400
> >>>
> >>> Status: Needs information => Open
> >>>
> >>> Maarten Fokkinga gave more information on the question:
> >>> Sound files (.wav and .oga) produce sounds with GNOME Player and with
> >>> Audacious.
> >>>
> >>> Installing Totem Video Player did not resolve the problem; I do have
> now:
> >>> /usr/bin/totem
> >>> and playing a video (MP4) does produce sound, but it also produces a
> >>> warning:
> >>> (totem:5229): Gtk-WARNING **: Calling Inhibit failed:
> >>> GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name
> >>> org.gnome.SessionManager was not provided by any .service files
> >>>
> >>> Command "gst-launch-1.0 -v -m audiotestsrc..." produces the error
> message
> >>> "command not found: gst-launch-1.0".
> >>> The description o package rel-gst-launch says "This package provides a
> >>> gst-launch plugin...", so I installed it. Alas; both "locate
> >>> gst-launch-1.0" and "which gst-launch-1.0" confirm that gst-launch-1.0
> is
> >>> not present (and similarly for gst-launch). However, "locate
> gst-launch"
> >>> gives:
> >>> /usr/lib/rygel-2.0/plugins/gst-launch.plugin
> >>> /usr/lib/rygel-2.0/plugins/librygel-gst-launch.so
> >>> /usr/share/doc/rygel-gst-launch
> >>> /usr/share/doc/rygel-gst-launch/changelog.Debian.gz
> >>> /usr/share/doc/rygel-gst-launch/copyright
> >>> /var/cache/apt/archives/rygel-gst-launch_0.20.3-1ubuntu2_i386.deb
> >>> /var/lib/dpkg/info/rygel-gst-launch.list
> >>> /var/lib/dpkg/info/rygel-gst-launch.md5sums
> >>>
> >>> I cannot find gst-launch nor gst-launch-1.0 with Lubuntu Software
> >>> Center, nor with Synaptic Package manager.
> >>>
> >>> What can/should I do next?
> >>>
> >>> --
> >>> You received this question notification because you are an answer
> >>> contact for Alarm Clock.
> >>>
> >>
> >> --
> >> If this answers your question, please go to the following page to let us
> >> know that it is solved:
> >>
> https://answers.launchpad.net/alarm-clock/+question/261400/+confirm?answer_id=3
> >>
> >> If you still need help, you can reply to this email or go to the
> >> following page to enter your feedback:
> >> https://answers.launchpad.net/alarm-clock/+question/261400
> >>
> >> You received this question notification because you asked the question.
>
> --
> You received this question notification because you are an answer
> contact for Alarm Clock.
>

I installed "pulsaudio".

Alas, alarm-clock still gives the same error message when I try to play the sound.

I executed "pulseaudio" in a terminal window, suspended it, and let it run in the backgroud. Then alarm-clock did not complain when I tried to play the sound BUT THERE WAS NO SOUND either.

In the meantime (I did not notice the precise timing), in the terminal window of pulseaudio there came a message (LOOK AT THE 2ND LINE):

E: [alsa-sink-Intel ICH] alsa-util.c: snd_pcm_avail() returned a value that is exceptionally large: 1209560 bytes (6856 ms).
E: [alsa-sink-Intel ICH] alsa-util.c: Most likely this is a bug in the ALSA driver 'snd_intel8x0'. Please report this issue to the ALSA developers.
E: [alsa-sink-Intel ICH] alsa-util.c: snd_pcm_dump():
E: [alsa-sink-Intel ICH] alsa-util.c: Hardware PCM card 0 'Intel 82801DB-ICH4' device 0 subdevice 0
E: [alsa-sink-Intel ICH] alsa-util.c: Its setup is:
E: [alsa-sink-Intel ICH] alsa-util.c: stream : PLAYBACK
E: [alsa-sink-Intel ICH] alsa-util.c: access : MMAP_INTERLEAVED
E: [alsa-sink-Intel ICH] alsa-util.c: format : S16_LE
E: [alsa-sink-Intel ICH] alsa-util.c: subformat : STD
E: [alsa-sink-Intel ICH] alsa-util.c: channels : 2
E: [alsa-sink-Intel ICH] alsa-util.c: rate : 44100
E: [alsa-sink-Intel ICH] alsa-util.c: exact rate : 44100 (44100/1)
E: [alsa-sink-Intel ICH] alsa-util.c: msbits : 16
E: [alsa-sink-Intel ICH] alsa-util.c: buffer_size : 16384
E: [alsa-sink-Intel ICH] alsa-util.c: period_size : 16384
E: [alsa-sink-Intel ICH] alsa-util.c: period_time : 371519
E: [alsa-sink-Intel ICH] alsa-util.c: tstamp_mode : ENABLE
E: [alsa-sink-Intel ICH] alsa-util.c: period_step : 1
E: [alsa-sink-Intel ICH] alsa-util.c: avail_min : 16384
E: [alsa-sink-Intel ICH] alsa-util.c: period_event : 0
E: [alsa-sink-Intel ICH] alsa-util.c: start_threshold : -1
E: [alsa-sink-Intel ICH] alsa-util.c: stop_threshold : 1073741824
E: [alsa-sink-Intel ICH] alsa-util.c: silence_threshold: 0
E: [alsa-sink-Intel ICH] alsa-util.c: silence_size : 0
E: [alsa-sink-Intel ICH] alsa-util.c: boundary : 1073741824
E: [alsa-sink-Intel ICH] alsa-util.c: appl_ptr : 596493
E: [alsa-sink-Intel ICH] alsa-util.c: hw_ptr : 882499
E: [alsa-sink-Intel ICH] alsa-util.c: snd_pcm_delay() returned a value that is exceptionally large: -488840 bytes (-2771 ms).
E: [alsa-sink-Intel ICH] alsa-util.c: Most likely this is a bug in the ALSA driver 'snd_intel8x0'. Please report this issue to the ALSA developers.
E: [alsa-sink-Intel ICH] alsa-util.c: snd_pcm_dump():
E: [alsa-sink-Intel ICH] alsa-util.c: Hardware PCM card 0 'Intel 82801DB-ICH4' device 0 subdevice 0
E: [alsa-sink-Intel ICH] alsa-util.c: Its setup is:
E: [alsa-sink-Intel ICH] alsa-util.c: stream : PLAYBACK
E: [alsa-sink-Intel ICH] alsa-util.c: access : MMAP_INTERLEAVED
E: [alsa-sink-Intel ICH] alsa-util.c: format : S16_LE
E: [alsa-sink-Intel ICH] alsa-util.c: subformat : STD
E: [alsa-sink-Intel ICH] alsa-util.c: channels : 2
E: [alsa-sink-Intel ICH] alsa-util.c: rate : 44100
E: [alsa-sink-Intel ICH] alsa-util.c: exact rate : 44100 (44100/1)
E: [alsa-sink-Intel ICH] alsa-util.c: msbits : 16
E: [alsa-sink-Intel ICH] alsa-util.c: buffer_size : 16384
E: [alsa-sink-Intel ICH] alsa-util.c: period_size : 16384
E: [alsa-sink-Intel ICH] alsa-util.c: period_time : 371519
E: [alsa-sink-Intel ICH] alsa-util.c: tstamp_mode : ENABLE
E: [alsa-sink-Intel ICH] alsa-util.c: period_step : 1
E: [alsa-sink-Intel ICH] alsa-util.c: avail_min : 16384
E: [alsa-sink-Intel ICH] alsa-util.c: period_event : 0
E: [alsa-sink-Intel ICH] alsa-util.c: start_threshold : -1
E: [alsa-sink-Intel ICH] alsa-util.c: stop_threshold : 1073741824
E: [alsa-sink-Intel ICH] alsa-util.c: silence_threshold: 0
E: [alsa-sink-Intel ICH] alsa-util.c: silence_size : 0
E: [alsa-sink-Intel ICH] alsa-util.c: boundary : 1073741824
E: [alsa-sink-Intel ICH] alsa-util.c: appl_ptr : 760333
E: [alsa-sink-Intel ICH] alsa-util.c: hw_ptr : 882543

ALAS, now audacious and GNOME MPlayer DO NOT produce sound anymore....

I've rebooted the system; pulseaudio seems automatically running:
$ ps -ax | grep pulseaudio
 1493 ? S<l 0: 00 /usr/bin/pulseaudio --start --log-target=syslog
 1755 pts/0 S+ 0: 00 grep pulseaudio

Still
(1) alarm-clock doesnot complain but doesnot produce sound, either (when trying to play sound).
(2) audacious and GNOME MPlayer do not produce sound (things have become worse...)

Also,
"gst-launch -v -m audiotestsrc ! audioconvert ! audioresample ! autoaudiosink"
still gives a huge error message (different than before):
Setting pipeline to PAUSED ...
/GstPipeline:pipeline0/GstAudioTestSrc:audiotestsrc0.GstPad:src: caps = audio/x-raw-int, endianness=(int)1234, signed=(boolean)true, width=(int)16, depth=(int)16, rate=(int)44100, channels=(int)1
Pipeline is PREROLLING ...
Got message #9 from element "autoaudiosink0" (state-changed): GstMessageState, old-state=(GstState)GST_STATE_NULL, new-state=(GstState)GST_STATE_READY, pending-state=(GstState)GST_STATE_VOID_PENDING;
Got message #10 from element "audioresample0" (state-changed): GstMessageState, old-state=(GstState)GST_STATE_NULL, new-state=(GstState)GST_STATE_READY, pending-state=(GstState)GST_STATE_VOID_PENDING;
...
and many more "Got message #x..." lines (with x comming from the range 11-39), and then:
...
/GstPipeline:pipeline0/GstAutoAudioSink:autoaudiosink0/GstPulseSink:autoaudiosink0-actual-sink-pulse: volume = 1,000000
/GstPipeline:pipeline0/GstAutoAudioSink:autoaudiosink0/GstPulseSink:autoaudiosink0-actual-sink-pulse: mute = FALSE
/GstPipeline:pipeline0/GstAutoAudioSink:autoaudiosink0/GstPulseSink:autoaudiosink0-actual-sink-pulse: volume = 1,000000
/GstPipeline:pipeline0/GstAutoAudioSink:autoaudiosink0/GstPulseSink:autoaudiosink0-actual-sink-pulse: mute = FALSE

It seems as if the (sound) system is completely erroneous now....

Best Johannes H. Jensen (joh) said : #9

Hmm, I don't know why pulseaudio shouldn't work. You can try uninstalling
pulseaudio and gstreamer0.10-pulseaudio, then install gstreamer1.0-alsa.

On Fri, Jan 30, 2015 at 10:11 PM, Maarten Fokkinga <
<email address hidden>> wrote:

> Question #261400 on Alarm Clock changed:
> https://answers.launchpad.net/alarm-clock/+question/261400
>
> Status: Answered => Open
>
> Maarten Fokkinga is still having a problem:
> I installed "pulsaudio".
>
> Alas, alarm-clock still gives the same error message when I try to play
> the sound.
>
> I executed "pulseaudio" in a terminal window, suspended it, and let it
> run in the backgroud. Then alarm-clock did not complain when I tried to
> play the sound BUT THERE WAS NO SOUND either.
>
> In the meantime (I did not notice the precise timing), in the terminal
> window of pulseaudio there came a message (LOOK AT THE 2ND LINE):
>
> E: [alsa-sink-Intel ICH] alsa-util.c: snd_pcm_avail() returned a value
> that is exceptionally large: 1209560 bytes (6856 ms).
> E: [alsa-sink-Intel ICH] alsa-util.c: Most likely this is a bug in the
> ALSA driver 'snd_intel8x0'. Please report this issue to the ALSA developers.
> E: [alsa-sink-Intel ICH] alsa-util.c: snd_pcm_dump():
> E: [alsa-sink-Intel ICH] alsa-util.c: Hardware PCM card 0 'Intel
> 82801DB-ICH4' device 0 subdevice 0
> E: [alsa-sink-Intel ICH] alsa-util.c: Its setup is:
> E: [alsa-sink-Intel ICH] alsa-util.c: stream : PLAYBACK
> E: [alsa-sink-Intel ICH] alsa-util.c: access : MMAP_INTERLEAVED
> E: [alsa-sink-Intel ICH] alsa-util.c: format : S16_LE
> E: [alsa-sink-Intel ICH] alsa-util.c: subformat : STD
> E: [alsa-sink-Intel ICH] alsa-util.c: channels : 2
> E: [alsa-sink-Intel ICH] alsa-util.c: rate : 44100
> E: [alsa-sink-Intel ICH] alsa-util.c: exact rate : 44100 (44100/1)
> E: [alsa-sink-Intel ICH] alsa-util.c: msbits : 16
> E: [alsa-sink-Intel ICH] alsa-util.c: buffer_size : 16384
> E: [alsa-sink-Intel ICH] alsa-util.c: period_size : 16384
> E: [alsa-sink-Intel ICH] alsa-util.c: period_time : 371519
> E: [alsa-sink-Intel ICH] alsa-util.c: tstamp_mode : ENABLE
> E: [alsa-sink-Intel ICH] alsa-util.c: period_step : 1
> E: [alsa-sink-Intel ICH] alsa-util.c: avail_min : 16384
> E: [alsa-sink-Intel ICH] alsa-util.c: period_event : 0
> E: [alsa-sink-Intel ICH] alsa-util.c: start_threshold : -1
> E: [alsa-sink-Intel ICH] alsa-util.c: stop_threshold : 1073741824
> E: [alsa-sink-Intel ICH] alsa-util.c: silence_threshold: 0
> E: [alsa-sink-Intel ICH] alsa-util.c: silence_size : 0
> E: [alsa-sink-Intel ICH] alsa-util.c: boundary : 1073741824
> E: [alsa-sink-Intel ICH] alsa-util.c: appl_ptr : 596493
> E: [alsa-sink-Intel ICH] alsa-util.c: hw_ptr : 882499
> E: [alsa-sink-Intel ICH] alsa-util.c: snd_pcm_delay() returned a value
> that is exceptionally large: -488840 bytes (-2771 ms).
> E: [alsa-sink-Intel ICH] alsa-util.c: Most likely this is a bug in the
> ALSA driver 'snd_intel8x0'. Please report this issue to the ALSA developers.
> E: [alsa-sink-Intel ICH] alsa-util.c: snd_pcm_dump():
> E: [alsa-sink-Intel ICH] alsa-util.c: Hardware PCM card 0 'Intel
> 82801DB-ICH4' device 0 subdevice 0
> E: [alsa-sink-Intel ICH] alsa-util.c: Its setup is:
> E: [alsa-sink-Intel ICH] alsa-util.c: stream : PLAYBACK
> E: [alsa-sink-Intel ICH] alsa-util.c: access : MMAP_INTERLEAVED
> E: [alsa-sink-Intel ICH] alsa-util.c: format : S16_LE
> E: [alsa-sink-Intel ICH] alsa-util.c: subformat : STD
> E: [alsa-sink-Intel ICH] alsa-util.c: channels : 2
> E: [alsa-sink-Intel ICH] alsa-util.c: rate : 44100
> E: [alsa-sink-Intel ICH] alsa-util.c: exact rate : 44100 (44100/1)
> E: [alsa-sink-Intel ICH] alsa-util.c: msbits : 16
> E: [alsa-sink-Intel ICH] alsa-util.c: buffer_size : 16384
> E: [alsa-sink-Intel ICH] alsa-util.c: period_size : 16384
> E: [alsa-sink-Intel ICH] alsa-util.c: period_time : 371519
> E: [alsa-sink-Intel ICH] alsa-util.c: tstamp_mode : ENABLE
> E: [alsa-sink-Intel ICH] alsa-util.c: period_step : 1
> E: [alsa-sink-Intel ICH] alsa-util.c: avail_min : 16384
> E: [alsa-sink-Intel ICH] alsa-util.c: period_event : 0
> E: [alsa-sink-Intel ICH] alsa-util.c: start_threshold : -1
> E: [alsa-sink-Intel ICH] alsa-util.c: stop_threshold : 1073741824
> E: [alsa-sink-Intel ICH] alsa-util.c: silence_threshold: 0
> E: [alsa-sink-Intel ICH] alsa-util.c: silence_size : 0
> E: [alsa-sink-Intel ICH] alsa-util.c: boundary : 1073741824
> E: [alsa-sink-Intel ICH] alsa-util.c: appl_ptr : 760333
> E: [alsa-sink-Intel ICH] alsa-util.c: hw_ptr : 882543
>
> ALAS, now audacious and GNOME MPlayer DO NOT produce sound anymore....
>
> I've rebooted the system; pulseaudio seems automatically running:
> $ ps -ax | grep pulseaudio
> 1493 ? S<l 0: 00 /usr/bin/pulseaudio --start
> --log-target=syslog
> 1755 pts/0 S+ 0: 00 grep pulseaudio
>
> Still
> (1) alarm-clock doesnot complain but doesnot produce sound, either (when
> trying to play sound).
> (2) audacious and GNOME MPlayer do not produce sound (things have become
> worse...)
>
> Also,
> "gst-launch -v -m audiotestsrc ! audioconvert ! audioresample !
> autoaudiosink"
> still gives a huge error message (different than before):
> Setting pipeline to PAUSED ...
> /GstPipeline:pipeline0/GstAudioTestSrc:audiotestsrc0.GstPad:src: caps =
> audio/x-raw-int, endianness=(int)1234, signed=(boolean)true, width=(int)16,
> depth=(int)16, rate=(int)44100, channels=(int)1
> Pipeline is PREROLLING ...
> Got message #9 from element "autoaudiosink0" (state-changed):
> GstMessageState, old-state=(GstState)GST_STATE_NULL,
> new-state=(GstState)GST_STATE_READY,
> pending-state=(GstState)GST_STATE_VOID_PENDING;
> Got message #10 from element "audioresample0" (state-changed):
> GstMessageState, old-state=(GstState)GST_STATE_NULL,
> new-state=(GstState)GST_STATE_READY,
> pending-state=(GstState)GST_STATE_VOID_PENDING;
> ...
> and many more "Got message #x..." lines (with x comming from the range
> 11-39), and then:
> ...
> /GstPipeline:pipeline0/GstAutoAudioSink:autoaudiosink0/GstPulseSink:autoaudiosink0-actual-sink-pulse:
> volume = 1,000000
> /GstPipeline:pipeline0/GstAutoAudioSink:autoaudiosink0/GstPulseSink:autoaudiosink0-actual-sink-pulse:
> mute = FALSE
> /GstPipeline:pipeline0/GstAutoAudioSink:autoaudiosink0/GstPulseSink:autoaudiosink0-actual-sink-pulse:
> volume = 1,000000
> /GstPipeline:pipeline0/GstAutoAudioSink:autoaudiosink0/GstPulseSink:autoaudiosink0-actual-sink-pulse:
> mute = FALSE
>
> It seems as if the (sound) system is completely erroneous now....
>
> --
> You received this question notification because you are an answer
> contact for Alarm Clock.
>

I obeyed your suggestions (uninstall pulseaudio and gstreamer0.10-pulseaudio; then installing gstreamer1.0-alsa). Also, I rebooted the system.
No sound (and no complaints) from alarm-clock, audacious, and GNOME Mplayer.

Then I realized that I had speakers attached to sound jacket, but not switched on...
Switching on the speakers... YES, sound works as it should. (Before I started this question, the sound came from the computer itself even though the speakers were plugged in and on status "off".) So, the problem has been solved in an acceptable way.

HOWEVER after unplugging the speakers from the computer, the computer's sound does not work, whereas it did before I started this question for help. I can certainly live with the solution thus far (but I would appreciate a suggestion how to repair this situation).

Many many thanks for your help, Johannes!

Thanks Johannes H. Jensen, that solved my question.

Peter Uithoven (p7ter) said : #12

I'm having the same issue.

The following command creates sound
gst-launch-1.0 -v -m audiotestsrc ! audioconvert ! audioresample ! autoaudiosink

So do other applications, like Firefox, VLC, etc.

I've installed:
- gstreamer0.10-alsa
- gstreamer1.0-als
- gstreamer0.10-pulsea
- gstreamer1.0-pulseau
- pulseaudio (1:4.0-0ubuntu11)
- gstreamer-tools (0.10.36-1.2ubun)

I'm on elementary OS 0.3.2 Freya (64-bit)
Which is based on Ubuntu 14.04 LTS