My adobe flash player is not working. I saw an update in the manager. Then most sites stopped working. What can I do?

Asked by Armando Montes De Oca III

I update every day from the update manager. I saw an adobe update downloading. Then my flash stopped working for some sites. I got sudo code from the web and purged adobe and then sudo re-installed. That got troublesome and, then I just used software center and, now have the Mozilla plug in. I uninstalled Gnash viewer. Still flash is not working with some sites. I would like to use sudo to fix the problem or just wait for the update in manager.

Question information

English Edit question
Adobe Flash Plugin Tools Edit question
No assignee Edit question
Solved by:
Armando Montes De Oca III
Last query:
Last reply:
Revision history for this message
Armando Montes De Oca III (mondymontes3) said :

Thank You

Revision history for this message
Armando Montes De Oca III (mondymontes3) said :

I just re-installed Gnash and everything seems to be fine now. Thank You for your time.

Revision history for this message
Armando Montes De Oca III (mondymontes3) said :

I love this stuff!

Revision history for this message
David A. Cobb (superbiskit) said :

Running xubuntu 11.10; up to date.

From the submission date on this (2012-03-28), I suspect I have the same problem.

I have tried just about every combination of: (xubuntyu-restricted-addons, -extras, gnash + mozilla-gnash-plugin, adobe download .tar.gz). One even crashed the browser. Most combinations show nothing at all in the space that would be a flash object. With only gnash, I get something -- it flickers; nothing useable but evidence that something is being loaded.

If I run Task-Manager while this is going on, I see a player being loaded -- then it goes away immediately. I have printed out both NSPR_LOG_FILE's and strace outputs. I don't _see_ anything peculiar. I "see" the player being loaded, then it appears to exit without any failure being logged; of course, then the application has problems because it cannot communicate with the plugin that is no longer there.

Armando: do you have one of the *-restricted-* packages installed? From prowling around here those looked like the most potentially helpful, but they don't seem to be.

If anyone can suggest something else to try, PLEASE post it.
If anyone can identify something I can capture that would be useful for debugging this, post that and I can generate a LOT of output.

site for testing: (Joining not required to play)

Revision history for this message
shara valery (sharavalery) said :

Did you try to disable your Hardware Acceleration? this can help you. I've been having this exact same problem for a couple weeks now. What's odd is that my Guest Account will play these without any problem, so it must be something to do with my overall Flash preferences. I visited to fix out you may also check out here.