Error while compiling - what's the reason?

Asked by Hans


When compiling I get the following error - what's the reason for this? Sorry I'm pretty new with linux...


scons: Reading SConscript files ...
Checking for C header file poll.h... (cached) no
Checking for C header file sys/epoll.h... (cached) no
Checking for pthread_create() in C library pthread... (cached) no
Checking for SSL_connect() in C library ssl... (cached) no
Checking for dlopen() in C library dl... (cached) no
Copy("/home/pyload/temp/adch/adchpp_2.9.0_source/build/debug-default/bin/lua", "lua")
scons: *** /home/pyload/temp/adch/adchpp_2.9.0_source/build/debug-default/bin/lua: File exists
ruby: no such file to load -- mkmf (LoadError)
Ruby libdir not found, skipping ruby module
Python.h not found, not building python extension
scons: done reading SConscript files.
scons: Building targets ...
Compiling build/debug-default/adchpp/adchpp.h.gch (shared precompiled header)
adchpp/adchpp.h:1:0: error: CPU you selected does not support x86-64 instruction set
scons: *** [build/debug-default/adchpp/adchpp.h.gch] Error 1
scons: building terminated because of errors.

Question information

English Edit question
ADCH++ Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Best poy (poy) said :

you have to add arch=x64 to the scons command (for example scons mode=release arch=x64 ). you can throw it in a file if you fear you might forget about it: create a file and write arch='x64' in it.

Revision history for this message
Hans (redder2) said :

Thanks poy, that solved my question.

Revision history for this message
Hans (redder2) said :

Thanks a lot poay! Worked perfectly! ADCH is now set up! Thanks again!