Minimum Share Size

Asked by Tanmay Balwa

I changed the setting in access.limits.lua

access.add_setting(‘minsharesize’, {
alias = { minss = true },

change = recheck_info,

help = “minimum share size allowed in bytes, 0 = disabled”,

value = 1000000000

Yet after restarting, users with less than minsharesize can still connect.

And in the ADCH++ v2.7.0 window i am getting an error

access.limits.lua:23: bad argument #1 to 'len' (string expected, got nil)

and then there is stack traceback information. I have taken a screenshot of the window with error as i couldn't copy the text.

Question information

English Edit question
ADCH++ Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Best poy (poy) said :

Lua files are not to be manually edited. in this case, it seems your editor has messed up some quotation marks.

use the following command instead:
+cfg minss 1073741824

Revision history for this message
Tanmay Balwa (tanmay-balwa) said :

Thanks poy, that solved my question.