Promlem with ADCH + + and Freshstuff.

Asked by T32770 on 2013-01-12

I've tried to put up a ADCH + + hub up, and have installed ADCH + +-PtokaX and Freshstuff. But I can not get freshstuff to run. I get this error (adchpp-ptokax.lua: 1834: Error loading the module "lfs" via "require") and do not know what that means?
I can not activate freshstuff.lua too

Can U help?

BR T32770
Sorry my English

[17:27:32] * FreshStuff3 5.0.1 detected PtokaX 0.4.1.2 as host app.
[17:27:32] <Bot> The categories file is corrupt or missing! Created a new one.
[17:27:32] <Bot> If this is the first time you run this script, or newly installed it, please copy your old releases.dat (if any) to freshstuff/data and restart the script. Thank you!
[17:27:32] * Loaded 0 releases in 0 seconds.
[17:27:32] * FreshStuff3 5.0.1 kernel loaded.
[17:27:32] <Bot> adchpp-ptokax.lua:1834: Error loading the module "lfs" via "require"
[17:27:32] <Hubtest> Loaded px/freshstuff.lua

Question information

Language:
English Edit question
Status:
Solved
For:
ADCH++-PtokaX Edit question
Assignee:
No assignee Edit question
Solved by:
poy
Solved:
2013-01-13
Last query:
2013-01-13
Last reply:
2013-01-13
eMTee (realprogger) said : #1

What is your OS, what version of ADCH++ you are running and what's the adchpp-ptokax script version?

T32770 (t32770) said : #2

Hi, Windows 8 now, but same problem in Windows 7 and adchpp-ptokax-rev108.

BR T3

Best poy (poy) said : #3

for freshstuff, you have to copy the lfs.dll file (found in the bin directory of ADCH++) to freshstuff/libnew (so that it sits next to pxlfs). for most scripts, no copy is necessary as they can locate the lib in the bin directory of ADCH++; but this is a required step for some scripts (including freshstuff).

T32770 (t32770) said : #4

Tnx M8

You have saved the day, I spent 10 hours yesterday and could not get it to work :-(

Thank you

BR T3

T32770 (t32770) said : #5

Thanks poy, that solved my question.

Seth Gordon (sethgordon) said : #6

this thread was helpful. had the same issue. i ALMOST figured it out on my own, wound up incorrectly putting the lfs file in the lib folder instead of libnew. saved me the time of making another thread :D