Help with Rincewind's Grimoire script on ADCH++-PtokaX

Asked by Kalel Shah on 2012-12-27

ADCH++ version is 2.9.0 (x86)
Rincewind's Grimoire version is 5.3.0 Lua 5.1 API2 Edition
OS is MS Windows 7 64-bit

I have put the Rincewind's Grimoire.lua file (along with the Rincewind's Grimoire and Rincewind's Scripts folders) in the Scripts directory of the ADCH++ folder. I have added Rincewind's Grimoire.lua in the script.xml file (after history.lua). But when I run ADCH++, this is what I get in the console window:

Error loading file: Rincewind's Grimoire.lua:8: attempt to index global 'Core' (a nil value)

Lines 8, 9 and 10 from the Rincewind's Grimoire.lua file are as follows:

if dofile(Core.GetPtokaXPath().."scripts/Rincewind's Grimoire/Lua/General/Globals/OpenFiles.lua") then
 loadfile(Core.GetPtokaXPath().."scripts/Rincewind's Grimoire/Lua/General/Globals/OpenFiles.lua")
end

The above file (OpenFIles.lua) exists in the given location. Can someone please help me here? How to set up the script in ADCH+++? I m using ADCH++-PtokaX (added before motd.lua)

Question information

Language:
English Edit question
Status:
Solved
For:
ADCH++-PtokaX Edit question
Assignee:
No assignee Edit question
Solved by:
Kalel Shah
Solved:
2012-12-27
Last query:
2012-12-27
Last reply:
Kalel Shah (coolboy-sex) said : #1

Never mind. I got the solution. I read the Expert's Guide of ADCH++ and realised that I had to add the script thorugh the hub context menu. :)