Routine crash with snow on screen and white noise

Asked by Alexandre Oberlin on 2013-05-07

Hi all,

I have been owning an AC100 for 2 years and tried Ubuntu from the start, but I never could really use it.

Today I installed Ubuntu 12.10 and it worked so great, with sound and external keyboard, external mouse and external 3G modem!

After about half an hour however, the old syndrome came back: sudden freeze, with snowy screen, eventually some lines, holding the power button being the only way out. The novelty was the white noise, since I did not have sound with the previous versions I tried ;-) After the first crash and reboot, the laptop crashes much quicker so I can’t use it any more than the initial half hour or so.

Do you think it is a hardware, firmware or Ubuntu problem. I hardly ran Android on it so I can’t say. Has anyone experienced a similar behavior ?

Any suggestion welcome,

Alexandre

Question information

Language:
English Edit question
Status:
Solved
For:
AC100_enablement Edit question
Assignee:
No assignee Edit question
Solved by:
Alexandre Oberlin
Solved:
2013-08-05
Last query:
2013-08-05
Last reply:
2013-05-07
Leon Romanovsky (leonro) said : #1

On Tue, May 7, 2013 at 4:46 PM, Alexandre Oberlin
<email address hidden> wrote:

> Do you think it is a hardware, firmware or Ubuntu problem. I hardly ran Android on it so I can’t say. Has anyone experienced a similar behavior ?
I will bet on hardware.

--
Leon Romanovsky | Independent Linux Consultant
        www.leon.nu | <email address hidden>

Alexandre Oberlin (alxobr) said : #2

So sad!

With such behavior, I suspected it could perhaps be heat related.

Snark (julien-puydt) said : #3

Is shutting down the only way out? Doesn't moving the screen a little help too?

I have similar symptoms, and I'm suspecting the hinges : when the screen display is frozen or only a little strange, moving the screen a little help (it doesn't if things have gotten worse).

Marc Dietrich (marvin24) said : #4

Your may try out this kernel https://launchpad.net/~marvin24/+archive/ppa/+files/linux-image-3.1.10-7-ac100_3.1.10-7.11_armhf.deb just for testing. It has some display related fixes.

Alexandre Oberlin (alxobr) said : #5

@Snark Thanks, I will try next time, and maybe some oil ;-) Now it has been working fine for 45 minutes!

@marvin24 I tried GDebi. The package's description says:
You likely do not want to install this package directly. Instead, install the linux-ac100 meta-package, which will ensure that upgrades work correctly, and that supporting packages are also installed.

What should I do?

Marc Dietrich (marvin24) said : #6

the package is not official, therefore the warning. Just ignore the warning. You can uninstall the kernel package later if you find out that it doesn't work for you.

Alexandre Oberlin (alxobr) said : #7

Thanks for the tip. I have been able to shut down properly last time. and will try this unofficial kernel as soon as the symptoms come back.

I had another strange behavior which also looked a bit like a hardware failure and nonetheless seems to have completely disappeared with 12.10: sometimes I had a hard time managing to start by hitting the power button. Now this is fine, so there I still keep hope for the snowy crash!

Cheers,

Alexandre

Snark (julien-puydt) said : #8

@marvin24: I'm running 3.1.10-7-ac100 version 3.1.10-7.14 now, so I don't think my display problems are fixed by the kernel you link to. And the fact that just moving the screen can fix the glitches sometimes points to the hinges (hardware problem).

Alexandre Oberlin (alxobr) said : #9

@Snark I have tried to move the screen with no effect. However, hitting Fn + F5 did stop the terrible sound, which might indicate there still was some life behind there. Moreover this partially cleaned up the screen. However the image was still frozen and the computer did not recover from the crash.

@marvin24 I am currently running linux-image-3.1.10-6-ac100. Next time I will then install the kernel you mentioned. I guess I will have to activate some diagnostic tools?

Alexandre

Marc Dietrich (marvin24) said : #10

no, just install it and see if the screen glitches are fixed.

Snark (julien-puydt) said : #11

Uh... I don't have any terrible sound, only graphical glitches, so perhaps I'm not getting the same as you.

Alexandre Oberlin (alxobr) said : #12

Hi,

@Snark Ain’t that strange: my crashes are also silent since I once disabled sound using Fn + F5 while frozen. Sound is still working quite well, and the AC100 (AC100-10D) quite a valuable little thing: I managed to fluently run TuxGuitar, a java MIDI application, with the software synthesizer Fluidsynth.

@marvin24 I just had one crash since I installed linux-image-3.1.10-7-ac100_3.1.10-7.11_armhf.deb. Now I usually reboot voluntarily after one hour or so, so that I don’t lose all my settings. A great improvement using 12.10 is that it allows to recover after a crash occurred while installing software.

Have a nice week-end,

Alexandre

Alexandre Oberlin (alxobr) said : #13

Hi again!

After having done the traditional "sudo apt-get update; sudo apt-get upgrade; sudo apt-get dist-upgrade" (with recovered crashes in between) I tried to install the Tegra2 proprietary driver by following the instructions in https://wiki.ubuntu.com/ARM/TEGRA/AC100#Graphics . This did not work because I had an error trying to execute "Software sources" in software-center. However this page also suggests in a tip to install glmark2-es2 and mesa-utils-extra, which I did. Now I have been running the AC100 for hours with ad-hoc wireless connection and I DID NOT GET THE SNOWY CRASH ANYMORE !

It looks like the problem is solved.

Cheers,

Alexandre

Alexandre Oberlin (alxobr) said : #14

Hi,

The problem still occurs when something is is attached to the USB port (3G modem or keyboard or both).

I am not 100% sure if it ever happened when nothing was connected to the USB port. However I remember that I could not use my USB keyboard in previous releases. I still need to check with only the modem attached.

Cheers,

Alexandre