Can I install armel package in Ubuntu 12.04 (armhf) for Toshiba AC100?

Asked by Ivan Zakharyaschev on 2013-01-04

coq package (a formal proof system) doesn't build for armhf (yet) -- https://bugs.launchpad.net/coq/+bug/935063 , but there is a package for armel.

Can I install armel coq in Ubuntu armhf (on Toshiba AC100), or it won't work?

(I've also posted the general question about armhf and armel compatibility at http://unix.stackexchange.com/q/60282/4319 .)

Oliver Grawert (ogra) said : #1

see http://wiki.debian.org/Multiarch/HOWTO (this indeed only works in ubuntu releases that still had armel (12.04 and 12.10)

Ivan Zakharyaschev (imz) said : #2

Thanks, this is helpful!

In 12.04, the stopper is emacsen-common:armel:

root@potka:~# apt-get install coq:armel
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 coq:armel : Depends: coq-theories:armel (= 8.3.pl4+dfsg-1) but it is not installable
             Depends: emacsen-common:armel but it is not installable
             Depends: libcoq-ocaml-vx397:armel
             Recommends: coqide:armel but it is not going to be installed or
                         proofgeneral:armel but it is not installable
E: Unable to correct problems, you have held broken packages.
root@potka:~# apt-get install emacsen-common:armel
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package emacsen-common:armel is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'emacsen-common:armel' has no installation candidate
root@potka:~# dpkg --listfiles emacsen-common
/.
/etc
/etc/emacs
/etc/emacs/site-start.el
/etc/emacs/site-start.d
/etc/emacs/site-start.d/00debian-vars.el
/usr
/usr/share
/usr/share/emacs
/usr/share/emacs/site-lisp
/usr/share/emacs/site-lisp/debian-startup.el
/usr/share/doc
/usr/share/doc/emacsen-common
/usr/share/doc/emacsen-common/sample-package-install-foo.gz
/usr/share/doc/emacsen-common/sample-package-remove-foo.gz
/usr/share/doc/emacsen-common/copyright
/usr/share/doc/emacsen-common/changelog.gz
/usr/share/doc/emacsen-common/debian-emacs-policy.gz
/usr/lib
/usr/lib/emacsen-common
/usr/lib/emacsen-common/packages
/usr/lib/emacsen-common/packages/install
/usr/lib/emacsen-common/packages/install/emacsen-common
/usr/lib/emacsen-common/packages/remove
/usr/lib/emacsen-common/packages/remove/emacsen-common
/usr/lib/emacsen-common/emacs-install
/usr/lib/emacsen-common/emacs-package-install
/usr/lib/emacsen-common/generate-install-list
/var
/var/lib
/var/lib/emacsen-common
/usr/lib/emacsen-common/emacs-remove
/usr/lib/emacsen-common/emacs-package-remove
root@potka:~#

emacsen-commn must probably be somehow adapted for multiarch...

Perhaps, I'll try switching to 12.10 as the next step.

Ivan Zakharyaschev (imz) said : #3

Cf. also a problem with emacs and multiarch -- https://bugs.launchpad.net/ubuntu/+source/emacs23/+bug/927434 .

Can you help with this problem?

Provide an answer of your own, or ask Ivan Zakharyaschev for more information if necessary.

To post a message you must log in.